Back to overview
Downtime

Truss app outage

Oct 20 at 07:59am PDT
Affected services
app2.gettruss.io

Resolved
Oct 20 at 10:28am PDT

Upstream issues resolved.

Updated
Oct 20 at 08:55am PDT

The outage appears to be due to network load balancing of our cloud provider. Our engineering team is continuing to monitor the upstream AWS outage as they work towards resolution. We are also exploring alternative ways to circumvent the issue.

Created
Oct 20 at 07:59am PDT

The Truss app is down due to a major upstream Amazon Web Services outage. Engineering is monitoring for ongoing developments and will continue to provide updates on this page.